2017-12-17 16:31 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001859openmediavaultBugpublic2017-11-30 14:38
ReporterSmurphy 
Assigned Tovotdev 
PrioritynormalSeverityblockReproducibilityalways
StatusassignedResolutionopen 
PlatformHP MIcroserver gen8 / x86_64OSDebianOS Version8.9
Product VersionErasmus (3.x) 
Target VersionFixed in Version 
Summary0001859: When configuring network (any), applying the changes fails due to a script execution error
DescriptionApplying any interface configuration change, results in:

Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; echo '-bond1' > /sys/class/net/bonding_masters 2>&1' with exit code '1':

Even adding +bond1 (and +bond0 - as after removing bond1, it tries to remove bond0) manually to the bonding_masters file results in that error message.

Even preparing the system with both entries prior applying the network interface changes, the error remains.
Steps To ReproduceAdd network interface, apply changes.

Note this has happened first while adding a bond interface. After removing the bond interface (revert) adding a regular eth1 Interface with another IP cause the same error to happen.
Trying to add eth0, eth1 bond0 or bond1 all result in the same error.

Additional InformationThe code states that this may not be required on debian 8.
After replacing the code removing the bond interfaces with /bin/true - the configuration change went through without a problem.
Note that this is not a fix, it was just a workaround.

root@nas:/usr/share/openmediavault/engined/module# diff -uN interfaces.inc interfaces.inc~
--- interfaces.inc 2017-11-30 12:32:12.081971974 +0100
+++ interfaces.inc~ 2017-11-30 12:19:50.361543460 +0100
@@ -71,8 +71,7 @@
        final public function deleteBondInterface($params) {
                // Note, this may not be necessary in Debian Jessie.
                // See http://backdrift.org/manage-linux-bonding-without-ifenslave-using-sysfs
- //$cmd = sprintf("echo '-%s' > /sys/class/net/bonding_masters",
- $cmd = sprintf("/bin/true",
+ $cmd = sprintf("echo '-%s' > /sys/class/net/bonding_masters",
                  $params['devicename']);
                $this->exec($cmd);
        }

Most probably, a check should be made for testing if bondX is actually available in bonding_masters, then only remove it.
But even with bond0/bond1 in that file, the error message occure. Hence - not really a fix.
TagsNo tags attached.
Product buildOMV 3.0.93
Attached Files

-Relationships
+Relationships

-Notes
There are no notes attached to this issue.
+Notes

-Issue History
Date Modified Username Field Change
2017-11-30 14:38 Smurphy New Issue
2017-11-30 14:38 Smurphy Status new => assigned
2017-11-30 14:38 Smurphy Assigned To => votdev
+Issue History