2017-12-17 16:25 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001855openmediavaultBugpublic2017-11-26 10:13
Reporterpetaramesh 
Assigned Tovotdev 
PriorityhighSeveritymajorReproducibilityhave not tried
StatusresolvedResolutionunable to reproduce 
PlatformOSDebianOS Version9.2
Product VersionArrakis (4.x) 
Target VersionFixed in VersionArrakis (4.x) 
Summary0001855: OMV web interface broken in Firefox 57 ?
DescriptionHello,

This has to be confirmed by others, but since I upgraded my Firefox to the new Firefox 57, OMV's Interface (4.0.9-1 or 4.0.10-1) doesn't work anymore : ONce logged in, clicking on the left panes tabs produce no effect.

The web interface still works good in Chromium, so I know it's a browser <-> interface issue.
Steps To ReproduceUse Firefox 57
Additional InformationTested on Arch Linux
TagsNo tags attached.
Product buildVersion: 4.0.10-1
Attached Files

-Relationships
+Relationships

-Notes

~0005037

votdev (administrator)

Can not reproduce that on Ubuntu.

~0005042

petaramesh (reporter)

Hello,

I can confirm that the reported issue doesn't currently exist on Ubuntu 17.04 running Firefox 57.

However, I can also confirm that it definitely exists on Arch's Firefox 57, even when :

- Firefox has been "refreshed" to "factory defaults"
- Firefox has been started in "safe mode" so no external or additional modules are loaded.

Precise symptoms are : Mouse clicks in OMV's web interface produce no result at all, except for clicking on the "OpenMediaVault" logo the causes a new brower tab to open and go to OMV's website.

Best regards.

~0005043

votdev (administrator)

To me it looks that it is a bug/regression in Firefox, otherwise it would not work on all platforms.

~0005045

petaramesh (reporter)

I add that the issue also exists on a 2nd (Manjaro Linux) machine, immediately after upgrade to Firefox 57.

~0005048

binuts (reporter)

Hello, I have the same problem since upgrade to firefox 57 with fedora linux 26 and 27, with two different machine.
Works fine with chromium 62.

With firefox, you can expend the left tab by press tab and enter.

~0005049

petaramesh (reporter)

Hi binuts,

I can confirm this. Following your hint for [TAB]-[Enter], I've discovered that the Interface still can be used the following way :

- Clicking mouse button doesn't activate an interface element, but does select it. Then pressing the spacebar does activate it.

Which means that where one used to "click", "click then spacebar" works.

That's not extremely user-friendly, still this makes OMV's interface usable in affected Firefox 57.

~0005050

votdev (administrator)

This issue is also not reproducable with Firefox 57 and Chrome 62.0.3202.94 on Windows 10
+Notes

-Issue History
Date Modified Username Field Change
2017-11-17 08:08 petaramesh New Issue
2017-11-17 08:08 petaramesh Status new => assigned
2017-11-17 08:08 petaramesh Assigned To => votdev
2017-11-17 08:08 petaramesh File Added: Screenshot_20171116_073557.png
2017-11-17 08:30 votdev Status assigned => closed
2017-11-17 08:30 votdev Resolution open => unable to reproduce
2017-11-17 08:30 votdev Fixed in Version => Arrakis (4.x)
2017-11-17 08:30 votdev Note Added: 0005037
2017-11-19 08:57 petaramesh Status closed => feedback
2017-11-19 08:57 petaramesh Resolution unable to reproduce => reopened
2017-11-19 08:57 petaramesh Note Added: 0005042
2017-11-19 12:51 votdev Note Added: 0005043
2017-11-19 23:59 petaramesh Note Added: 0005045
2017-11-19 23:59 petaramesh Status feedback => assigned
2017-11-25 20:41 binuts Note Added: 0005048
2017-11-26 10:04 petaramesh Note Added: 0005049
2017-11-26 10:13 votdev Status assigned => resolved
2017-11-26 10:13 votdev Resolution reopened => unable to reproduce
2017-11-26 10:13 votdev Note Added: 0005050
+Issue History