2017-11-20 23:37 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001850openmediavaultBugpublic2017-11-12 10:16
Reporterpetaramesh 
Assigned Tovotdev 
PrioritynormalSeveritymajorReproducibilityalways
StatusfeedbackResolutionreopened 
PlatformOSDebianOS Version9.2
Product VersionArrakis (4.x) 
Target VersionFixed in Version 
Summary0001850: Getting rid of a "phantom" disk
DescriptionHi again (sorry for bothering).

The issue with OMV dealing with multi-disks BTRFS volumes, confusing it (for which a fix is upcoming) had caused an error to be produced while trying to mount an EXTERNAL drive using OMV's interface (the displayed error concerning the already mounted BTRFS).

Since, it seems that OMV "remembers" the presence of the "phantom" external drive - which is not there anymore - as any modification to "filesystems" recreates its entry in fstab, and rrdtools tries to produce graphs for this non-existing drive.

I've poked around to try and discover where OMV puts its database information, and couldn't find any flat text file, xml or json, mentioning the phantom drive.

So how could I access and remove garbage from OMV's DB or config ?

TIA (again...)
TagsNo tags attached.
Product buildVersion: 4.0.8-1
Attached Files

-Relationships
+Relationships

-Notes

~0005024

votdev (administrator)

OMV stores the mount point configuration in its database. If you mount an external drive these mount points are still displayed. The mount point information is static because it is needed by the shared folder management, too. This is by design and can not be changed. It is to keep the data consistency. OMV is the master of the system and creates the configuration out of the information stored in the database. Related to mount points there is no magic that takes care about correct mount points and existing filesystems. The user must take care about this. Note, OMV is a NAS which always should use internal drives that are not removed. External drives should only be used for 'USB Backup' plugin or equivalent plugins for data exchange.

~0005029

petaramesh (reporter)

Reopening just for a clarification (sorry).

In the above comment, do you mean that I should never attach an external USB drive, mount it temporarily using OMV's interface, use if (ie for performing file copies / rsync between the NAS internal drives and the external one), then properly unmount and remove it ?

TIA.
+Notes

-Issue History
Date Modified Username Field Change
2017-11-05 12:40 petaramesh New Issue
2017-11-05 12:40 petaramesh Status new => assigned
2017-11-05 12:40 petaramesh Assigned To => votdev
2017-11-06 14:14 votdev Note Added: 0005024
2017-11-06 14:14 votdev Status assigned => closed
2017-11-06 14:14 votdev Resolution open => no change required
2017-11-12 10:16 petaramesh Status closed => feedback
2017-11-12 10:16 petaramesh Resolution no change required => reopened
2017-11-12 10:16 petaramesh Note Added: 0005029
+Issue History