2017-11-20 23:37 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001848openmediavaultBugpublic2017-11-12 10:23
Reporterpetaramesh 
Assigned Tovotdev 
PrioritylowSeverityminorReproducibilityN/A
StatusfeedbackResolutionreopened 
PlatformOSDebianOS Version9.2
Product VersionArrakis (4.x) 
Target VersionFixed in Version 
Summary0001848: Disks rrdtools graphs disappeared
DescriptionHello,

On the "system informations tab" I used to have nice rrdtools graphs, including a "disks" graphs that was properly showing the growing amount of data inside my NAS, so I found it really useful.

However, the "disk" graph has all of a sudden simply... disappeared, leaving an empty page - also taking the "refresh" button away with it - where all the other graphs (load, cpu, memory...) are still there and continue to be properly updated.

Any clue ?

TIA, and kind regards.
TagsNo tags attached.
Product buildVersion: 4.0.8-1
Attached Files

-Relationships
+Relationships

-Notes

~0005019

votdev (administrator)

Looks like an browser issue. Which browser are you using? Please enable the dev tools of the browser and check for errors.

~0005020

petaramesh (reporter)

I tried both Firefox 56.0.2, and Chromium 62.0.3202.75

Dev tools show that on tabs *other* than disks, the browser receives a div class "xpanel-rrdgraph" that it doesn't receive on the disks tab.

As a side note, I can see that the graphs are still produced :

root@nasgul:/# ll /var/lib/openmediavault/rrd/
total 540
-rw-r--r-- 1 root root 18210 nov. 5 11:45 cpu-0-day.png
-rw-r--r-- 1 root root 15872 nov. 5 11:45 cpu-0-hour.png
-rw-r--r-- 1 root root 15565 nov. 5 11:45 cpu-0-month.png
-rw-r--r-- 1 root root 24195 nov. 5 11:45 cpu-0-week.png
-rw-r--r-- 1 root root 14579 nov. 5 11:45 cpu-0-year.png
-rw-r--r-- 1 root root 12393 nov. 5 11:45 df-root-day.png
-rw-r--r-- 1 root root 11840 nov. 5 11:45 df-root-hour.png
-rw-r--r-- 1 root root 12715 nov. 5 11:45 df-root-month.png
-rw-r--r-- 1 root root 13220 nov. 5 11:45 df-root-week.png
-rw-r--r-- 1 root root 12799 nov. 5 11:45 df-root-year.png
-rw-r--r-- 1 root root 11965 nov. 5 11:45 df-srv-dev-disk-by-label-store_1-day.png
-rw-r--r-- 1 root root 12342 nov. 5 11:45 df-srv-dev-disk-by-label-store_1-hour.png
-rw-r--r-- 1 root root 13903 nov. 5 11:45 df-srv-dev-disk-by-label-store_1-month.png
-rw-r--r-- 1 root root 14202 nov. 5 11:45 df-srv-dev-disk-by-label-store_1-week.png
-rw-r--r-- 1 root root 14264 nov. 5 11:45 df-srv-dev-disk-by-label-store_1-year.png
-rw-r--r-- 1 root root 17093 nov. 5 11:45 interface-eno1-day.png
-rw-r--r-- 1 root root 20028 nov. 5 11:45 interface-eno1-hour.png
-rw-r--r-- 1 root root 15474 nov. 5 11:45 interface-eno1-month.png
-rw-r--r-- 1 root root 21518 nov. 5 11:45 interface-eno1-week.png
-rw-r--r-- 1 root root 14869 nov. 5 11:45 interface-eno1-year.png
-rw-r--r-- 1 root root 18479 nov. 5 11:45 load-day.png
-rw-r--r-- 1 root root 15913 nov. 5 11:45 load-hour.png
-rw-r--r-- 1 root root 14458 nov. 5 11:45 load-month.png
-rw-r--r-- 1 root root 26815 nov. 5 11:45 load-week.png
-rw-r--r-- 1 root root 13760 nov. 5 11:45 load-year.png
-rw-r--r-- 1 root root 17593 nov. 5 11:45 memory-day.png
-rw-r--r-- 1 root root 15806 nov. 5 11:45 memory-hour.png
-rw-r--r-- 1 root root 17326 nov. 5 11:45 memory-month.png
-rw-r--r-- 1 root root 25270 nov. 5 11:45 memory-week.png
-rw-r--r-- 1 root root 16754 nov. 5 11:45 memory-year.png

~0005025

votdev (administrator)

Can not reproduce this with Chromium 62.0.3202.75 and Firefox 56.0. Seems to be a problem on the user side.

~0005030

petaramesh (reporter)

For the record here's what I have now :

I temporarily reattached to the NAS an externale USB drive that I had used in the past (and mounting it by the time had produced some errors with OMV confusing multi-volume BTRFS filesystems).

Now that this issue has been fixed in 4.0.9-1, I'm happy to report that my external drive mounts and umounts without any error, and that fstab is properly updated accordingly.

The interesting thing (re the present bugreport) is that, as soon as the EXTERNAL drive is mounted, rrdtool graphs for ALL filesystems automagically reappear.

And as soon as I unmount the external FS, the disk usage graphs immediately disappear again.

So this clearly relates to having a disk "missing" which has, at some point in time, been known to OMV.

NOw my question boils down to : How do I make OMV database forget about removed filesystems, once for all ?
+Notes

-Issue History
Date Modified Username Field Change
2017-11-05 11:14 petaramesh New Issue
2017-11-05 11:14 petaramesh Status new => assigned
2017-11-05 11:14 petaramesh Assigned To => votdev
2017-11-05 11:14 petaramesh File Added: Screenshot_20171105_111035.png
2017-11-05 11:42 votdev Note Added: 0005019
2017-11-05 11:58 petaramesh Note Added: 0005020
2017-11-06 14:17 votdev Status assigned => closed
2017-11-06 14:17 votdev Resolution open => unable to reproduce
2017-11-06 14:17 votdev Note Added: 0005025
2017-11-12 10:23 petaramesh Status closed => feedback
2017-11-12 10:23 petaramesh Resolution unable to reproduce => reopened
2017-11-12 10:23 petaramesh Note Added: 0005030
+Issue History