2018-02-18 01:51 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001830openmediavaultBugpublic2018-02-10 00:18
Reporterpeteruithoven 
Assigned Tovotdev 
PrioritynormalSeveritymajorReproducibilityalways
StatusassignedResolutionopen 
PlatformFirefox v56OSElemenentary OSOS VersionLoki
Product VersionErasmus (3.x) 
Target VersionFixed in Version 
Summary0001830: Language selection broken in Firefox
DescriptionThe language selection dropdown seems broken in Firefox.

Even when clearing data for the http://raspberrypi/ domain.
Looking in the Console there seems to be no javascript error, or relevant warning. Looking in the Network panel there is no issue loading assets (the file globals.js which contains the supported languages is loaded for example).
When I have the Debug panel pause on all exeptions it does get paused. But the exception itself seems to be undefined?
The code seems to be transpiled and Firefox doesn't seem to handle the sourcemaps correctly, so it will be hard to figure out what part of the code is triggering this exception. I've included a screenshot.
(I just noticed that when I have the the debugger continue the sourcemaps are actually loaded, so it seems like this exception is thrown before Firefox can retrieve the sourcemaps.

This also happens in a Firefox Private browsing window.

What also might be interesting, the normally hidden dropdown div containing all the language options isn't created in my Firefox.

It works fine for me in Chrome and when I set Chrome to pause, even on caught exceptions I do not see the above mentioned exception.

Is there a separate issue queue I should be reporting this to? The issue queue on the repo itself doesn't seem to be enabled.

Also reported on forum: http://forum.openmediavault.org/index.php/Thread/17836-Unable-to-login-Language-field-empty/

Might be related to: http://bugtracker.openmediavault.org/view.php?id=1787
Steps To Reproduce1. Go to web admin
2. Try clicking on language
(Nothing will happen.
TagsWebGUI
Product buildOMV_3_0_88_RaspberryPi_2_3_4.9.41.img.xz
Attached Files

-Relationships
+Relationships

-Notes

~0004971

votdev (administrator)

Can not reproduce this with Firefox 56.0 (64-bit) on Ubuntu.

~0004972

peteruithoven (reporter)

I retried this with Firefox 56.0 in Safemode, to make sure it's not caused by extensions or custom settings, but that doesn't help.

Like mentioned in the forum post, I also tried:
- Firefox beta 57.0b8 (64-bit)
- Firefox developer edition (57.0b8 (64-bit))
- Firefox Nightly (58.0a1 (2017-10-15) (64-bit))

~0004974

votdev (administrator)

Last edited: 2017-10-15 20:34

View 2 revisions

Due the fact that all mentioned versions are beta it could also be a regression in Firefox. That there are no problems in Chrome is an additional indication for that.

~0005118

Alex131089 (reporter)

This is a bug related to ExtJS.
FF 58.0.1 & 52.6.0 (ESR) affected too.

Found with this search: https://bugzilla.mozilla.org/buglist.cgi?quicksearch=extjs
-> https://bugzilla.mozilla.org/show_bug.cgi?id=1301327

Workaround client-side, in about:config : dom.w3c_touch_events.enabled=0 (default to 2 in mentioned versions ; https://stackoverflow.com/questions/25024197/how-to-make-sure-touch-events-are-enabled-in-firefox-desk-top-browser)

No fix from ExtJS it seems (https://www.sencha.com/forum/showthread.php?328814-Ext-6-2-0-don-t-listen-mouse-events-when-touch-or-pointer-events-are-supported).
Some hints in https://www.sencha.com/forum/showthread.php?328814-Ext-6-2-0-don-t-listen-mouse-events-when-touch-or-pointer-events-are-supported&p=1195647&viewfull=1#post1195647 :
 - https://www.sencha.com/forum/showthread.php?310206-ExtJ-6-doest-not-work-on-Linux-with-Firefox-45&p=1155250&viewfull=1#post1155250
 - https://www.sencha.com/forum/showthread.php?336762-Examples-don-t-work-in-Firefox-52-touchscreen&p=1174857&viewfull=1#post1174857

~0005119

votdev (administrator)

Is anyone able to check whether this fix works? https://www.sencha.com/forum/showthread.php?336762-Examples-don-t-work-in-Firefox-52-touchscreen&p=1174857&viewfull=1#post1174857

~0005125

Alex131089 (reporter)

I wanted to try today, by adding the overrides in /var/www/openmediavault/js/ext-overrides.js (is that the correct way ? Just pasting the forum code at the end of the file ?), but I wasn't able to reproduce the bug without the overrides.
The only difference I see from the last time I tried is I'm on the same network this time, while the last time I used a socks5 proxy (ssh tunnel) to access omv (the reason I used firefox). I'll try again when I'm in the same situation.
I guess 0001855 and 0001871 with the mentioned 0001787 are all related ?
+Notes

-Issue History
Date Modified Username Field Change
2017-10-14 17:58 peteruithoven New Issue
2017-10-14 17:58 peteruithoven Status new => assigned
2017-10-14 17:58 peteruithoven Assigned To => votdev
2017-10-14 17:58 peteruithoven File Added: Screenshot from 2017-10-13 11.06.10.png
2017-10-14 17:58 peteruithoven Tag Attached: WebGUI
2017-10-15 20:15 votdev Note Added: 0004971
2017-10-15 20:24 peteruithoven Note Added: 0004972
2017-10-15 20:34 votdev Note Added: 0004974
2017-10-15 20:34 votdev Note Edited: 0004974 View Revisions
2018-02-01 19:00 Alex131089 Note Added: 0005118
2018-02-01 19:55 votdev Note Added: 0005119
2018-02-10 00:18 Alex131089 Note Added: 0005125
+Issue History