2017-12-17 16:39 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001799openmediavaultKnown Issuepublic2017-12-16 18:50
Reporterdonh 
Assigned Tovotdev 
PrioritynormalSeverityminorReproducibilityalways
StatusassignedResolutionreopened 
Platform3.0.86OSOS Version3.0.86
Product VersionErasmus (3.x) 
Target VersionFixed in VersionErasmus (3.x) 
Summary0001799: 3.0.86 iso
DescriptionAfter install update in web ui fails with a bunch of firmware updates.
apt-get update
apt-get upgrade also does not install all the firmware updates.
apt-get dist-upgrade corrects the problem.
Steps To Reproduceclean install of 3.0.86 iso. Try to update by web ui.
TagsNo tags attached.
Product build
Attached Files

-Relationships
+Relationships

-Notes

~0004948

raulfg3 (reporter)

select all except ADI and RALINK firmware and update works fine, once update the fails no longers happens. and pending firmware dissapears from webGUI/list

as a workarrond a new ISO are wellcome.

~0004950

votdev (administrator)

Last edited: 2017-09-29 12:20

View 2 revisions

This is a general behaviour and won't be fixed.

The packages displayed in the UI and are selected to be updated are installed via dpkg which does not resolve new dependencies. As new dependencies are not added to packages during a release (this is a default Debian behavior), this only happens if you are using external package repositories or backports.

Because OMV3 uses backport kernels this may happen from time to time. A workaround is to use the CLI and 'apt-get dist-upgrade' (this is important to install packages with new dependencies) to install the packages.

~0005070

donh (reporter)

This continues in 3.0.94 .

This is a general behaviour and won't be fixed. ??? Maybe that looses something in translation.

A new user's first impression will be that updates do not work in the web ui. There is only one first impression. Why have it be that things are broken? I have never seen this error on any other appliance. I know things will come up from time to time. I am not sure how you build the iso but it might be as easy as updating what it starts with.

Thanks
 

~0005072

ryecoaaron27 (reporter)

The only way this could be fixed is if selecting all available updates executed a dist-upgrade instead of installing all enumerated packages. If would fail on the command line as well if you typed out each package name. I think the web interface needs an "Upgrade All" button as well.

~0005074

votdev (administrator)

Should be fixed in openmediavault 4.0.15, see https://github.com/openmediavault/openmediavault/commit/99ab5e756fc76757f90780501c5437942f8c6bf5.

~0005078

donh (reporter)

Thanks
+Notes

-Issue History
Date Modified Username Field Change
2017-08-03 02:32 donh New Issue
2017-08-03 02:32 donh Status new => assigned
2017-08-03 02:32 donh Assigned To => votdev
2017-08-03 08:18 votdev Category Bug => Known Issue
2017-08-03 08:18 votdev Product build 3.0.86 =>
2017-09-29 11:33 raulfg3 Note Added: 0004948
2017-09-29 12:18 votdev Status assigned => closed
2017-09-29 12:18 votdev Resolution open => no change required
2017-09-29 12:18 votdev Fixed in Version => Erasmus (3.x)
2017-09-29 12:18 votdev Note Added: 0004950
2017-09-29 12:20 votdev Note Edited: 0004950 View Revisions
2017-12-12 03:16 donh Status closed => feedback
2017-12-12 03:16 donh Resolution no change required => reopened
2017-12-12 03:16 donh Note Added: 0005070
2017-12-14 02:49 ryecoaaron27 Note Added: 0005072
2017-12-15 21:27 votdev Note Added: 0005074
2017-12-16 18:50 donh Note Added: 0005078
2017-12-16 18:50 donh Status feedback => assigned
+Issue History