2017-11-20 23:39 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001742openmediavaultBugpublic2017-06-04 11:05
ReporterRomaNNN 
Assigned Tovotdev 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionno change required 
Product Version 
Target VersionFixed in VersionErasmus (3.x) 
Summary0001742: Focused line twitches when "File systems" page is dynamically refreshing
DescriptionVideo in attachment.
Additional InformationOMV Erasmus (3.0.76)
TagsNo tags attached.
Product build
Attached Files

-Relationships
+Relationships

-Notes

~0004749

votdev (administrator)

Fixed in openmediavault 3.0.77, see https://github.com/openmediavault/openmediavault/commit/e93bda34a3ff65d18d329070f43f08267a4f1e6c.

~0004781

RomaNNN (reporter)

Not fixed. It doesn't drop now, but selection sometimes moves to another line. See the second video in attachment.

~0004783

votdev (administrator)

Last edited: 2017-06-02 17:09

View 2 revisions

The fix improves the behaviour a little bit. But finally it can not be solved completely because after the content is updated the previous selected line has to be selected again to update the toolbar conditions. Updating the toolbar conditions and reselecting the row(s) takes some time at all. I think there can't be done more to make it more smoother because everything that is related to the issue now is depending on the ExtJS code.

~0004785

RomaNNN (reporter)

Ok, maybe post this issue on the Sencha forum?

https://www.sencha.com/forum/forumdisplay.php?80-Ext-Bugs

In theory it can be fixed by remember last selection after calculate new data, before update tact.

~0004788

votdev (administrator)

Believe me, everything possible is done to reduce flickering. Check the source (with deep knowledge how Sencha ExtJS is implemented works internally) and you'll see that no other solution is possible.
+Notes

-Issue History
Date Modified Username Field Change
2017-05-16 23:52 RomaNNN New Issue
2017-05-16 23:52 RomaNNN Status new => assigned
2017-05-16 23:52 RomaNNN Assigned To => votdev
2017-05-16 23:52 RomaNNN File Added: Screencast_05-17-2017_12:35:46 AM.webm
2017-05-17 13:27 votdev Status assigned => resolved
2017-05-17 13:27 votdev Resolution open => fixed
2017-05-17 13:27 votdev Fixed in Version => Erasmus (3.x)
2017-05-17 13:27 votdev Note Added: 0004749
2017-06-02 16:59 RomaNNN Status resolved => feedback
2017-06-02 16:59 RomaNNN Resolution fixed => reopened
2017-06-02 16:59 RomaNNN Note Added: 0004781
2017-06-02 16:59 RomaNNN File Added: Screencast_06-02-2017_05:47:16 PM.webm
2017-06-02 17:08 votdev Note Added: 0004783
2017-06-02 17:09 votdev Note Edited: 0004783 View Revisions
2017-06-02 17:43 RomaNNN Note Added: 0004785
2017-06-02 17:43 RomaNNN Status feedback => assigned
2017-06-04 11:05 votdev Status assigned => closed
2017-06-04 11:05 votdev Resolution reopened => no change required
2017-06-04 11:05 votdev Note Added: 0004788
+Issue History