2017-11-20 23:42 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001690openmediavaultBugpublic2017-04-10 16:44
Reporterzdeno 
Assigned Tovotdev 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionunable to reproduce 
PlatformPentium G3220, 4GB RAMOSDebianOS Version8.7.1
Product VersionErasmus (3.x) 
Target VersionFixed in Version 
Summary0001690: cant create network share
Descriptionwhen im trying to create network share, i cannot becouse i stucks in "Device" choice
Steps To ReproduceSMB/CIFS > Shares > Add > Shared Folder (+) > Device
Tagssmb
Product build
Attached Files

-Relationships
+Relationships

-Notes

~0004608

votdev (administrator)

You need to create and mount a file system first. Have you done that?

~0004609

zdeno (reporter)

of course I did. Im using latest erasmus version. I alredy have files on that drive, OMV see partitions, see the RAID but dont see drive to smb share.

~0004614

votdev (administrator)

I can not reproduce this issue.

Please SSH into the system as user 'root' and execute the following commands:

$ monit stop omv-engined
$ omv-engined -d -f

Then try to create a share again. Did you see any error messages in the omv-engined output?

~0004673

zdeno (reporter)

Hi,
reproduction is easy, just download clear latest Debian and install OMV.
Here is log: http://pastebin.com/vk2YxAgb

~0004674

votdev (administrator)

Please post the output of

$ omv-confdbadm read "conf.system.filesystem.mountpoint"

~0004675

zdeno (reporter)

omv@server:~$ sudo omv-confdbadm read "conf.system.filesystem.mountpoint"
[]


just []

~0004676

votdev (administrator)

That is the problem. You have to select a file system and mount it via WebUI. Then you can create shares on it.

~0004677

votdev (administrator)

Please reopen if you think the problem still exists.

~0004683

zdeno (reporter)

but the "mount" option is grey (cannot click on that) and the unmount option is clickable, in table i see in "Mounted" column "yes". Im running RAID 1 on 2 HDDs, i can see RAID drives correctly.

~0004685

zdeno (reporter)

now i tried to make another disk drive in VM and when i format and mount it in webif it works. But I have 2 2TB disk in RAID1 and I cannot format that drive. Have you any idea how to make it working?

~0004686

zdeno (reporter)

okay, i find a fix, when you umount FS from terminal and then mount it via OMV from webif it works, you need to reboot system via webif to save that settings. You can close thread, maybe find some way to fix this. Thank you for your time
+Notes

-Issue History
Date Modified Username Field Change
2017-03-02 15:48 zdeno New Issue
2017-03-02 15:48 zdeno Status new => assigned
2017-03-02 15:48 zdeno Assigned To => votdev
2017-03-02 15:48 zdeno Tag Attached: smb
2017-03-02 15:59 votdev Note Added: 0004608
2017-03-02 15:59 votdev Product Version => Erasmus (3.x)
2017-03-02 16:14 zdeno Note Added: 0004609
2017-03-03 00:01 votdev Note Added: 0004614
2017-03-21 10:09 zdeno Note Added: 0004673
2017-03-21 10:22 votdev Note Added: 0004674
2017-03-21 10:44 zdeno Note Added: 0004675
2017-03-22 08:40 votdev Note Added: 0004676
2017-03-22 08:41 votdev Status assigned => closed
2017-03-22 08:41 votdev Resolution open => no change required
2017-03-22 08:41 votdev Note Added: 0004677
2017-04-01 11:01 zdeno Status closed => feedback
2017-04-01 11:01 zdeno Resolution no change required => reopened
2017-04-01 11:01 zdeno Note Added: 0004683
2017-04-04 12:05 zdeno Note Added: 0004685
2017-04-04 12:05 zdeno Status feedback => assigned
2017-04-04 13:10 zdeno Note Added: 0004686
2017-04-10 16:44 votdev Status assigned => closed
2017-04-10 16:44 votdev Resolution reopened => unable to reproduce
+Issue History